[tex-live] please update to libpng 1.6.2

Werner LEMBERG wl at gnu.org
Fri May 24 07:30:59 CEST 2013

>     [latest libpng] and the comments following, however, it seems
>     that some action on the pdftex side is probably necessary
>     also...
> Not practical at this point.
>     Alternatively, we might stay with libpng 1.5.16...
> Almost as bad.
>    [mpost distortion bug]

It's fortunate that pdftex doesn't produce PNGs, then an update would
be *really* necessary due to a serious bug introduced in 1.6.0 (and
fixed in 1.6.2) causing the creation of invalid files.

> In the future, evidently I will have to abjectly beg you to test
> earlier than two days before the purported deadline, maybe even test
> Taco's releases independent of TL, since it's obvious that you are
> trying many things that no one else does.

I don't think so. :-) I'm sure that the lilypond's METAFONT code is
quite normal *for a font*; the only unusual thing is to emit a lot of
tracing messages which get postprocessed by other tools.  Maybe the
GUST people would have seen this problem also if they had used the
current SVN for creating the various fonts they maintain.

> (Not surprising, given Lilypond's needs, et al.)  Code does not
> become "production-ready" via random miracles; people have to
> actually use it.

Sorry for that.  I haven't paid attention to the deadline, and I don't
regularly update my TeXLive SVN which usually always works for me out
of the box.  This is the first time since years that a bunch of such
problems happen at the same time.

BTW, the libpng issue can be fixed by running the
`png-fix-too-far-back' binary (which comes with recent libpng
versions) on affected PNG images, and I was able to successfully
continue my lilypond build after doing this.


More information about the tex-live mailing list