[OS X TeX] Russian characters contained in included .pdf do not appear in compiled document

Alan Munn amunn at gmx.com
Mon Dec 20 01:11:28 CET 2010


On Dec 19, 2010, at 6:19 PM, Manuel wrote:

>
> On 19/12/2010, at 23:52, Alan Munn wrote:
>
>>
>> Well we know what's happened now, but not why: the original  
>> document has 6 fonts embedded in it; the file created by pdfpages  
>> has 5.  The difference is that the original document has  
>> CenturySchl-Bold embedded twice, but with different encodings: one  
>> is Roman and the other is Custom.  I suspect that pdflatex itself  
>> is 'cleaning up' the multiple embeddings incorrectly.  Here's a  
>> solution:
>>
>> Process your file with xelatex instead of pdflatex; it doesn't have  
>> this problem on my test document.  (There may be other aspects of  
>> pdfpages that might not work with xelatex, but it won't harm to try.)
>>
>>
>> Alan
>>
>
> ...and: bang! - it worked. With XeLaTeX everything is fine again and  
> my compiled document is as it should be. Thank you, Alan, and David,  
> Claus, Alain, for your kind help.


I'm glad it worked.  I've filed a bug report with the pdftex folk.

Alan

-- 
Alan Munn
amunn at gmx.com




-------------- next part --------------
----------- Please Consult the Following Before Posting -----------
TeX FAQ: http://www.tex.ac.uk/faq
List Reminders and Etiquette: http://email.esm.psu.edu/mac-tex/
List Archive: http://tug.org/pipermail/macostex-archives/
TeX on Mac OS X Website: http://mactex-wiki.tug.org/
List Info: http://email.esm.psu.edu/mailman/listinfo/macosx-tex



More information about the macostex-archives mailing list