[OS X TeX] hyperref & beamer

Dr. Clea F. Rees cfrees at imapmail.org
Tue Sep 23 00:17:41 CEST 2008


There is apparently an issue with the combination of beamer and
hyperref in TL 2008 (at least with updates - don't know if either
package is affected).

Processing a presentation file, I see this in the console output:
...
Package hyperref Warning: Option `pdfpagelabels' is turned
off(hyperref)                because \thepage is undefined.

Hyperref stopped early
)
*hyperref using driver hpdftex*
(/usr/local/texlive/2008/texmf-dist/tex/latex/hyperref/hpdftex.def)
...

Googling suggests this is an incompatibility between beamer and more
recent versions of hyperref.

A bug report I found (reported to debian for some reason) suggested the
following work around:

\pagenumbering{arabic}
\documentclass...
 	\mode<presentation>
     	{
 	      \setbeamertemplate{sidebar left}{\thispdfpagelabel{\insertframenumber}}
     	}

Then I see this:
...
Hyperref stopped early
)
*hyperref using driver hpdftex*
(
/usr/local/texlive/2008/texmf-dist/tex/latex/hyperref/hpdftex.def)
...

Questions:
- what implications does the original error have?
- what implications does the fix have? will there be remaining issues?
   will there be side-effects?

This is the first beamer presentation I've typeset with TL 2008 and I'm
not sure what to check for. Usually, this wouldn't matter too much but
this is to be presented at a job interview so I'm worried about the
possibility of unexpected surprises.

It is not straightforward for me to revert to TL 2007 because I've
changed various things in texmf-local and my personal texmf directory.
Although these are theoretically reversible, I'd much rather not have
to if I can help it. I'm hoping someone has used this beamer/hyperref
combination (with or without the work around) and can let me know if
any problems came up.

Mac OS X 10.4.11 PPC

I usually present using Acrobat Pro. I'm using version 7.1.0.

The presentation is fairly customised (in template terms) but pretty
straightforward, I think. I don't need any external links to work -
only those internal to the presentation itself. It is basically
graphics and text - no multimedia files, for example. I'm hoping
whatever is getting switched off in hyperref won't affect this or won't
affect this with the work around (which I don't really understand), at
least.

Thanks,
cfr
-------------- next part --------------
----------- Please Consult the Following Before Posting -----------
TeX FAQ: http://www.tex.ac.uk/faq
List Reminders and Etiquette: http://www.esm.psu.edu/mac-tex/list/
List Archive: http://tug.org/pipermail/macostex-archives/
TeX on Mac OS X Website: http://mactex-wiki.tug.org/
List Info: http://email.esm.psu.edu/mailman/listinfo/macosx-tex



More information about the macostex-archives mailing list