[OS X TeX] SyncTeX and Beamer

Jonathan Kew jonathan at jfkew.plus.com
Sat Sep 6 00:47:37 CEST 2008


On 5 Sep 2008, at 11:42 PM, Peter Vamos wrote:

> Installed MacTeX 2008 10.5.4 on an Intel Mac without a hitch, thank  
> you Dick and all those involved.
>
> Was curious to try out SyncTeX. Alas, it doesn't seem to work with  
> the Beamer class.
>
> Specifically, it works from the source to the Preview as advertised  
> but command clicking in Preview will just highlight the command  
> \end{frame} for the appropriate frame. Switching back to Search  
> performs as before, and will, (usually) highlight the relevant input  
> in source.
>
> So for me at least, Search beats SyncTeX in a Beamer document. Am I  
> missing something? (Yes I do have the the .SyncTex.gz file  
> generated.) Can someone else also reproduce this behaviour?

I can confirm that this is a problem; I've seen the same behavior. I  
think it arises because of how beamer processes and packages up the  
slide contents. I'm curious to know if Jérôme's latest update to the  
synctex-parser code (that's the part used by the editor/viewer side of  
the process, not the *tex engines) will improve this, but have not yet  
had time to experiment with it. Sometime soon.....

JK

----------- Please Consult the Following Before Posting -----------
TeX FAQ: http://www.tex.ac.uk/faq
List Reminders and Etiquette: http://www.esm.psu.edu/mac-tex/list/
List Archive: http://tug.org/pipermail/macostex-archives/
TeX on Mac OS X Website: http://mactex-wiki.tug.org/
List Info: http://email.esm.psu.edu/mailman/listinfo/macosx-tex



More information about the macostex-archives mailing list