[OS X TeX] Flowcharts

Matthew Inglis m.j.inglis at warwick.ac.uk
Sat Jul 30 17:35:54 CEST 2005


Hello all,

I am trying to get "Flow" to work on OS 10.4, but am having some  
difficulties.
<http://www.tex.ac.uk/tex-archive/help/Catalogue/entries/flow.html>

I've built the flow.c file, to produce a flow.out file, but when I  
try to use it with, for example, this:
------------------------
Right
Box
   This is
   the first
   box.
Box 8 1
   And this is the second
------------------------

it says:

flow error : can't interpret line 1
\begin{picture}(0.000000,0.000000)(0.000000,0.000000)
% picture environment flowchart generated by flow 0.99e
\end{picture}
logout
[Process completed]

However, a colleague using Windows gets this:

\begin{picture}(13.000000,2.000000)(0.000000,-2.000000)
% picture environment flowchart generated by flow 0.99e
\put(0.0000,-2.0000){\framebox(4.0000,2.0000)[c]{\shortstack[c]{
This is\\
the first\\
box.
}}}
\put(4.0000,-1.0000){\vector(1,0){1.0000}}
\put(5.0000,-1.5000){\framebox(8.0000,1.0000)[c]{\shortstack[c]{
And this is the second
}}}
\end{picture}


Iit has been suggested to me that the problem may be to do with DOS/ 
UNIX/Mac line endings, but I've used TextWrangler to try all of these  
versions with no success.

I'm no expert in C, building, or the picture environment, so was  
hoping someone might be able to illuminate what is going wrong.

Best wishes

Matthew.
--------------------- Info ---------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
           & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Post: <mailto:MacOSX-TeX at email.esm.psu.edu>





More information about the Macostex-archives mailing list