[OS X TeX] imagemagick and libiconv

Bruno Voisin bvoisin at mac.com
Mon Mar 22 10:20:22 CET 2004

Le 22 mars 04, à 09:44, Steffen Lund Hokland a écrit :

> I can't install the latest version of imagemagick (I don't actually 
> know if I need to, but I tend to keep the packages up-to-date not 
> knowing any better). According to i-Installer Imagemagick has the 
> dependency problem:
>> ## File /usr/local/lib/libiconv.dylib is available.
>> ## File /usr/lib/libiconv.dylib is available.
>> Dependency requirements not fulfilled as one and only one of the 
>> checked files should be present.

This means you have both /usr/lib/libiconv.dylib installed as a part of 
Panther (OS X 10.3) and one /usr/local/lib/libiconv.dylib installed 
before Panther as an i-Package.
> and I need to install libiconv. This however I can't due to another 
> dependency problem:
>> ## Required  unavailable file /usr/lib/libiconv.dylib is available.
>> Dependency requirements not fulfilled as files that should be 
>> unavailable are present.
> Should I just don't bother or remove one of the above installations 
> (and in that case, which) or both?

You need to remove /usr/local/lib/libiconv.dylib and things should 
proceed smoothly (try "Remove" from the corresponding i-Package, and 
then install ImageMagick again).

Bruno Voisin
Please see <http://www.esm.psu.edu/mac-tex/> for list
guidelines, information, and LaTeX/TeX resources.

More information about the macostex-archives mailing list