[lltx] Hyphenation in LuaLaTeX

Vladimir Lomov lomov.vl at gmail.com
Thu Sep 30 07:27:12 CEST 2010

I'm trying to find out how to enable hyphenation in LuaLaTeX for Russian.

I made simple example with Russian text but lualatex don't hyphenate
the text. According to log the file with Russian patterns is loaded. I
tried French, German, Polish and Dutch languages and they work well
(though there is small problem with Polish but I think this is related
with the engine itself).

Any ideas what could be the source of the problem?

Also I notice that XeLaTeX and LuaLaTeX gives slightly different
results on the same file.

I attach all necessary files.

My environment: TeX Live 2010 (with fresh updated packages) and luatex
compiled from source (SVN).
System: linux x86_64.

About test:
One could run all files either by lualatex or xelatex. If one compare
results from xelatex and lualatex one could see that lualatex gives
more compact lines but sometimes words are not hyphenated. See for
example German or Polish text.

All texts are taken from wikipedia (de, fr, nl, pl, ru parts).

For reference I attached also pdf and log files produced by lualatex
and xelatex.

P.S. OT: I wonder how many ML users have xz utility
(http://tukaani.org/xz/)? Usual it gives files smaller than bzip2 of

WBR, Vladimir Lomov
-------------- next part --------------
A non-text attachment was scrubbed...
Name: hyphen.tar.bz2
Type: application/x-bzip2
Size: 240736 bytes
Desc: not available
URL: <http://tug.org/pipermail/lualatex-dev/attachments/20100930/43003841/attachment-0001.bz2>

More information about the lualatex-dev mailing list